La, j’ai besoin d’aide :



L’intelligence collective, Internet, toussa toussa, je suis sur que l’un d’entre vous peut m’aider :

Le « problème » : Flattr.

Je vous explique : j’ai un souci avec le plugin Flattr et WordPress.

Le problème, en détail :

J’ai installé le plugin Flattr pour WordPress, que vous pouvez trouver à l’adresse suivante : http://wordpress.org/extend/plugins/flattr/

Une fois le plugin installé et activé, une étape d’installation et de paramétrage est nécéssaire, elle se déroule en 8 étapes :

1 ) Vous connecter sur votre compte flattr.

2 ) Enregistrer votre blog entant qu’application Flattr afin les clés Flattr de votre application (elles vont vous permettre de lier votre blog au compte Flattr et de faire communiquer les deux interfaces).

3 ) Renseigner les champs qui vont bien dans la création de l’application.

4 ) Selectionner le type d’application, dans le cas du plugun Flattr, il faut l’enregistrer entant qu’application de type « navigateur ».

5 ) Renseigner votre callback, (votre domaine de rappel, il correspond à l’adresse de votre site ou blog le plus généralement).

6 ) Copier coller les clés obtenues, à la création de l’application, dans le plugin Flattr de WordPress.

7 ) Autoriser votre application à rentrer en interface avec votre compte Flattr.

8 ) Si vous est bon, normalement, on obtient les informations du compte Flattr ainsi que le nom d’utilisateur dudit compte.

J’arrive jusqu’à l’étape 7 et là, c’est le drame.

Lorsque j’essaye d’autoriser l’application, une erreur m’est retournée : « An error with the sent parametrs occurred. »

L’adresse de la page de l’erreur est : http://api.flattr.com/oauth/authorize?oauth_token=&access_scope=read,readextended,click,publish

Les manipulations déjà effectuées :

J’ai vérifié mon module wordpress, il est à jour, en version 3.1.2
J’ai vérifié mon plugin wordpress, il est à jour selon la page du plugin.
J’ai supprimé et recrée l’application sur Flattr.com afin de générer de nouvelles clés, même problème.
J’ai désinstallé (proprement) l’application Flattr, je l’ai aussi supprimé du blog, via ftp, même souci.
J’ai testé sur 3 ordinateurs, des fois que… et avec 3 navigateurs différents, Internet Explorer 8, Firefox 4 et Google Chrome.
J’ai vérifié le paramétrage de mon hébergement, le c-url est présent et pas de soucis de pare feu.

Mais le problème et le message d’erreur sont toujours là.

Représentation du problème :

Flattr est sur mon compte, à chaque nouveau post crée, une entrée Flattr est automatiquement générée sur leur site…donc, une partie du plugin fonctionne.

Cependant, lorsque je suis connecté sur mon interface Flattr, je ne vois pas ce contenu dans mon compte…il est donc sur Flattr, mais pas à moi, pas sur le bon compte voir sur aucun compte qui sait.

EDIT : je viens de m’entretenir avec le créateur du plugin, en fait, tant que mon contenu n’est pas Flattré, il n’apparait pas dans mon compte, les posts sont donc bien les miens, ils ne vont pas ailleurs ou quoi que ce soit d’autre. C’est donc une partie du problème qui est résolue, maintenant…passons à la seconde : pourquoi j’ai un message d’erreur quand j’essaye de lier mon blog à mon compte Flattr?

Pourquoi je m’acharne ?

C’est vrai, je pourrais très bien lâcher l’affaire…mais non. J’aime Flattr, ce à quoi il sert, ce qu’il représente (une alternative au financement des créateurs de contenus), je veux faire partie de l’expérience Flattr (bon, et acessoirement, parce que j’ai traduit une petite partie de l’interface française de Flattr, donc je me sens impliqué dans le bouzin, voyez).

Mais là, je sèche.

Je pense que le souci est dans cette partie de l’url « oauth_token=&access », après le «token=», je devrais avoir une code, qui correspond à un jeton d’autorisation de communication entre Flattr et mon blog. J’imagine que ce code via Open Auth doit être automatiquement généré, mais chez moi, ça ne fonctionne pas.

J’en fais donc appel à l’intelligence collective et la force qu’est Internet afin de m’aider à comprendre ce qu’il se passe et à régler le problème.

A défaut, si vous ne connaissez pas Flattr, relayez l’information, peut être que quelqu’un aura la réponse.

Merci énormément à tout ceux qui feront suivre cette demande d’assistance.

Vous aimez cet article? Partagez-le ;-)

TwitterGoogle +LinkedInMail
Flattr !

3 commentaires to “La, j’ai besoin d’aide :”

  1. avatar

    Bonjour, je ne sais pas si vous avez toujours ce problème, mais je connais le même problème pour mon blog.

    Je pense avoir une piste sans pour autant avoir de solution (pour le moment).

    L’idée c’est que sur la page de gestion du plugin Flattr, à l’étape 5, il y a marqué :
    « You must use http://www.monsite.org as callback domain. »

    (www.monsite.org est grisé)

    De l’autre côté, lorsqu’on crée une nouvelle application, et qu’on est sensé rentrer le « callback domain » en question (www.monsite.org) dans la case du bas (Callback URL), dès lors qu’on valide le formulaire, on remarque sur la page suivante que le callback domain est devenu http://www.monsite.org au lieu de rester http://www.monsite.org (le formulaire a rajouté automatiquement le http://).

    Je me demande s’il n’y a pas une incidence dans notre problème.

    Merci de me tenir au courant si vous avancez sur la question, je ferai de même 😉

  2. avatar

    Marrant, lorsque j’écrit w w w . m o n s i t e . o r g dans votre formulaire de commentaire, lui aussi rajoute automatiquement le http:// dans le résultat.
    Pour reformuler clairement le problème en feintant le formulaire :

    L’idée c’est que sur la page de gestion du plugin Flattr, à l’étape 5, il y a marqué :
    « You must use w w w . m o n s i t e . o r g as callback domain. »

    ( w w w . m o n s i t e . o r g est grisé)

    De l’autre côté, lorsqu’on crée une nouvelle application, et qu’on est sensé rentrer le « callback domain » en question (w w w . m o n s i t e . o r g) dans la case du bas (Callback URL), dès lors qu’on valide le formulaire, on remarque sur la page suivante que le callback domain est devenu http://www.monsite.org au lieu de rester w w w . m o n s i t e . o r g (le formulaire a rajouté automatiquement le http://).

    • avatar

      Bonsoir, c’est une piste à étudier, je vois ce à quoi vous pensez, mais il me semble avoir testé.

      Je suis intéressé par vos recherches sur le sujet, qui n’est toujours pas réglé depuis le temps 🙁